Page 1 of 1

Azteeg X3 Pro configuration issues

Posted: Sat Aug 09, 2014 3:24 pm
by mhackney
I'm pulling my hair out. I had my X3 Pro working fine months ago. I switched over to a Smoothie for a while then back to RAMBo (building and testing printers and moving things around). I gave my working RAMBo to my son after he blew the thermistor ports on his RAMBo a new mini kossel he's configuring. So I thought I would resurrect the X3 Pro and get all 4 of my Kraken extruders operational again.

I have everything wired up as before. I downloaded a copy of the latest Repetier yesterday. I worked through the Configuration.h and got things set up. Power up and movement is perfect, no issues there. But, I only see a temp reading on my hot bed and none on the single hot end I hooked up. I swapped the hot bed and hot end thermistors and verified that the hot end thermistor is working fine. I picked through pins.h and the configuration for extruder 1 and all seems fine:

// Analog input pin for reading temperatures or pin enabling SS for MAX6675
// Which pin enables the heater

TEMP_0_PIN is defined as 13 and HEATER_0_PIN as 10 in pins.h

I moved the hot end thermistor to each of the 5 open thermistor ports and none of them seem ti be mapped to 13.

The other odd issue is that on the hot bed, I read the temp but I'm not getting power to the Onyx when I set the temp. I measured V on both the hot bed terminals thinking I may have wired up the wrong one but both read in the low milli volts. The HAVE_HEATED_BED is true.

Anyone configure a recent Repetier download for an X3 Pro? Or have any idea what I'm missing?


Re: Azteeg X3 Pro configuration issues

Posted: Sat Aug 09, 2014 10:43 pm
by mhackney
Figured it out. Either the pin assignment for thermistor 1 is incorrect or I have a bad thermistor port. I was able to verify the other 4 ports worked. Not sure why T0 port is not working. Does anyone have T0 working and if so, what pin is assigned to it.

The non-working heat bed turned out to be a bad connection. Now everything is working great and I'm back up and printing.