PID Autotune Difficulty RmaxV2 to RmaxV3 Conversion

The new for 2016 RostockMAX v3!
Post Reply
SethGrace
Plasticator
Posts: 5
Joined: Thu Sep 20, 2018 12:22 am

PID Autotune Difficulty RmaxV2 to RmaxV3 Conversion

Post by SethGrace »

Hey guys,

I've recently upgraded a RmaxV2 with a dual-extrusion system. I'm now running Rmaxv3 firmware with a couple of the parameters changed for my build.

The firmware I'm using is here:
https://github.com/seemecnc/Firmware/archive/master.zip

The printer is set to Rostock Max v3 and the number of extruders to 2. For some reason, I can't seem to get the following PID autotune commands to work after issuing them over Octoprint:

HotEnd:
M303 P0 S210 X0
Bed:
M303 P1 S70 X0

The printer just holds temperature for an extended period of time and then sends an error message about autotune timeout. Other commands sent over the terminal, e.g. "G28", "G29", "M104 S150" work just fine. The autotune commands worked fine before I made the dual extrusion upgrade and re-flashed the firmware with the Printer set to Rmaxv3. Does anyone have an idea why my autotune commands might not be working? I haven't yet re-flashed the firmware with the Printer set to RmaxV2 and re-issued the autotune commands, but I imagine they'd work as they did before. I wouldn't imagine this is an Octoprint issue, but I could be wrong.
Attachments
20201003_120600.jpg
20201003_120600.jpg (173.04 KiB) Viewed 146 times

SethGrace
Plasticator
Posts: 5
Joined: Thu Sep 20, 2018 12:22 am

Re: PID Autotune Difficulty RmaxV2 to RmaxV3 Conversion

Post by SethGrace »

And... it looks like it's Octoprint for the Fail. I wrote the autotune commands to SD card and they executed just fine. Not sure how to look up the EEPROM and see the new values but I'd expect they've been written in fine. Octoprint has been giving me difficulties ever since the dual extrusion modification for some reason.. :/

SethGrace
Plasticator
Posts: 5
Joined: Thu Sep 20, 2018 12:22 am

Re: PID Autotune Difficulty RmaxV2 to RmaxV3 Conversion

Post by SethGrace »

Well, it looks like I spoke too soon. The HotEnd PID autotune command works fine off of the SD card. The one for the bed: "M303 P1 S75 X0" does not work. Not sure if "P1" is recognized as the bed heater for a RmaxV2 running V3 firmware.

Post Reply

Return to “RostockMAX v3”