Search found 33 matches

by AlanKilian
Tue Nov 19, 2019 5:12 pm
Forum: Troubleshooting
Topic: Why doesn't this print a circle?
Replies: 4
Views: 554

Re: Why doesn't this print a circle?

I'm trying to generate circles, and when I try using a single G2 code I get no motion.

When I use two G2 with half-circles, it previews fine, but prints wrong.

It looks like two half-circles offset by about 5mm in the Y axis.

Any ideas?
by AlanKilian
Tue Nov 19, 2019 5:10 pm
Forum: Troubleshooting
Topic: Why doesn't this print a circle?
Replies: 4
Views: 554

Why doesn't this print a circle?

Both Simplify and NCViewer preview this as a circle, but when I print it, it get two semicircles offset by about 5mm in Y.
by AlanKilian
Tue Nov 19, 2019 9:56 am
Forum: Troubleshooting
Topic: Duet Ethernet file upload unreliable.
Replies: 8
Views: 791

Re: Duet Ethernet file upload unreliable.

OK, I "updated" to the latest files provided by SeeMeCNC and even though I didn't see a firmware revision change, I can now upload and download 94 megabyte files of G code and get the exact contents back, so we'll have to chalk this on up to "unknown". If anyone suspects an issue, have them try upda...
by AlanKilian
Mon Nov 18, 2019 11:04 am
Forum: Troubleshooting
Topic: Duet Ethernet file upload unreliable.
Replies: 8
Views: 791

Re: Duet Ethernet file upload unreliable.

Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
Firmware Electronics: Duet Ethernet 1.02 or later
Firmware Version: 2.02(RTOS) (2018-12-24b1)
Web Interface Version: 1.22.6

Are there later revisions from SeeMeCNC I can try?
by AlanKilian
Mon Nov 18, 2019 10:10 am
Forum: Troubleshooting
Topic: Duet Ethernet file upload unreliable.
Replies: 8
Views: 791

Re: Duet Ethernet file upload unreliable.

I'll check the version this morning and get it to you. Do you have a Duet 2 Ethernet you can test on? Just upload a large multimegabyte text file, download it and compare the two files. It doesn't have to be GCode or anything, just a large file. I'll also ask on the Duet forum, but I figured since t...
by AlanKilian
Sun Nov 17, 2019 12:19 pm
Forum: Troubleshooting
Topic: Duet Ethernet file upload unreliable.
Replies: 8
Views: 791

Re: Duet Ethernet file upload unreliable.

1) I have a duet 2 like what was available when the Rostock Max 3 to 3.2 conversion was started. 2) I do not see a CRC check option in the DWC version recommended by SeeMeCNC. Can you help me find it? Are you suggesting I update to a version of firmware different than the firmware listed in the SeeM...
by AlanKilian
Sat Nov 16, 2019 11:11 am
Forum: Troubleshooting
Topic: Duet Ethernet file upload unreliable.
Replies: 8
Views: 791

Duet Ethernet file upload unreliable.

I am having a problem where I upload a large file using the web interface, and it has incorrect data when it gets to the printer. The file size is correct, but an occasional character is incorrect. (Rostock Max V3 upgraded to V3.2 with Duet/Ethernet) I know this by both downloading the file using th...
by AlanKilian
Fri Apr 21, 2017 11:08 am
Forum: Troubleshooting
Topic: Extruder skipping steps after the recommended procedure.
Replies: 1
Views: 857

Extruder skipping steps after the recommended procedure.

I'm interested in calibrating the E-Steps for my extruder and I'm having some problems. Machine: Rostock Max V3 / RamBo Firmware revision: 0.92.2 Firmware date: 20170201 Filament: Hatchbox PLA White Controls: Octoprint When I set the hot-end to 220C and extrude 100mm of filament using the "Cont...
by AlanKilian
Thu Apr 20, 2017 1:31 pm
Forum: Troubleshooting
Topic: Extrusion problems with your HE280 equipped printer? READ ME!
Replies: 20
Views: 12752

Re: Extrusion problems with your HE280 equipped printer? READ ME!

I'm interested in calibrating the E-Steps for my extruder and I'm having some problems. Machine: Rostock Max V3 / RamBo Firmware revision: 0.92.2 Firmware date: 20170201 Filament: Hatchbox PLA White Controls: Octoprint When I set the hot-end to 220C and extrude 100mm of filament using the "Cont...
by AlanKilian
Wed Mar 22, 2017 5:28 pm
Forum: Troubleshooting
Topic: Motors not working
Replies: 4
Views: 1213

Re: Motors not working

If you manually move the carriage down away from the limit switches and type G28 into a terminal, does anything move?
by AlanKilian
Wed Mar 22, 2017 5:24 pm
Forum: Troubleshooting
Topic: Heated Bed won't shut off Rostock V3
Replies: 6
Views: 1501

Re: Heated Bed won't shut off Rostock V3

Could you post the first hundred lines or so of your G code?
by AlanKilian
Sun Mar 12, 2017 6:50 pm
Forum: Troubleshooting
Topic: Heated bed erratic behaviour
Replies: 7
Views: 1395

Re: Heated bed erratic behaviour

Are you using the controls to set the bed temp and not starting a print? Mine does that also. I think there's a timer that turns the bed heat off a certain time after no printing.
by AlanKilian
Tue Feb 28, 2017 10:44 pm
Forum: Troubleshooting
Topic: HE280 keeps unplugging mid print
Replies: 3
Views: 1261

Re: HE280 keeps unplugging mid print

There's a model for a clip you can print. That solved my unplugging issue.

I don't have a link to the model.

Maybe someone can find it and link to it for others.
by AlanKilian
Tue Feb 28, 2017 10:41 pm
Forum: Troubleshooting
Topic: Accelerometer is not working
Replies: 25
Views: 3950

Re: Accelerometer is not working

YES!!! And we learned something together.
by AlanKilian
Tue Feb 28, 2017 8:30 am
Forum: Troubleshooting
Topic: Accelerometer is not working
Replies: 25
Views: 3950

Re: Accelerometer is not working

OK, Using the non-searchable RamBo schematics is driving me nutso, but I have something interesting. I <think> the accelerometer interrupt does not come up the thermister line, but comes up the PS_ON line. It's pin #7 on the HE280 board. A Green wire on my board which goes to a two-pin connector wit...
by AlanKilian
Mon Feb 27, 2017 9:56 pm
Forum: Troubleshooting
Topic: Accelerometer is not working
Replies: 25
Views: 3950

Re: Accelerometer is not working

Tomorrow I'll get you the wiring by checking my working system.
by AlanKilian
Mon Feb 27, 2017 5:09 pm
Forum: Troubleshooting
Topic: Accelerometer is not working
Replies: 25
Views: 3950

Re: Accelerometer is not working

I appreciate it and am just trying to make sure I am understanding what you are saying and have checked it. I looked at the RamBo schematic and the accelerometer uses four wires in the harness: GND You have this correct or all hell would be breaking loose! I2C communications. You have these correct...
by AlanKilian
Mon Feb 27, 2017 4:39 pm
Forum: Troubleshooting
Topic: [Solved] G92 E0 causes a lot of extrusion.
Replies: 31
Views: 7968

Re: [Solved] G92 E0 causes a lot of extrusion.

OK, I made a video to demonstrate.

Enjoy. It's not likely to win any YouTube awards. :-)

https://youtu.be/plyCrqTqO8s
by AlanKilian
Mon Feb 27, 2017 4:13 pm
Forum: Troubleshooting
Topic: [Solved] G92 E0 causes a lot of extrusion.
Replies: 31
Views: 7968

Re: [Solved] G92 E0 causes a lot of extrusion.

G28 (in any flavor) doesn't interact with the E axis at all. When I look at the code, I see it CLEARLY interacting with the E axis. case 28: //G28 Home all Axis one at a time { uint8_t homeAllAxis = (com->hasNoXYZ() && !com->hasE()); if(com->hasE()) Printer::currentPositionSteps[E_AXIS] = 0...
by AlanKilian
Mon Feb 27, 2017 4:05 pm
Forum: Troubleshooting
Topic: [Solved] G92 E0 causes a lot of extrusion.
Replies: 31
Views: 7968

Re: [Solved] G92 E0 causes a lot of extrusion.

Did you TRY the code I posted?

How about I undo my change and make a video?
by AlanKilian
Mon Feb 27, 2017 4:04 pm
Forum: Troubleshooting
Topic: [Solved] G92 E0 causes a lot of extrusion.
Replies: 31
Views: 7968

Re: [Solved] G92 E0 causes a lot of extrusion.

G92 E0 Doesn't cause the extruder to move, but REMOVING G92 E0 prevents the extruder from moving during a home operation.

How's that instead?
by AlanKilian
Mon Feb 27, 2017 12:24 pm
Forum: Troubleshooting
Topic: [Solved] G92 E0 causes a lot of extrusion.
Replies: 31
Views: 7968

Re: [Solved] G92 E0 causes a lot of extrusion.

Once again, G92 E0 moves nothing. g. However, G92 E0 resets the extruder actual position to zero, so the G28 X0 causes the extruder to go to its last known position and it makes a big pile of molten filament. It's a bug in G28 when used with the X0 parameter CAUSED by the G92 E0. Remove the G92 E0 ...
by AlanKilian
Sat Feb 25, 2017 5:58 pm
Forum: Troubleshooting
Topic: [Solved] G92 E0 causes a lot of extrusion.
Replies: 31
Views: 7968

Re: G92 E0 causes a lot of extrusion.

G28 X0 will cause the effector platform to wipe the nozzle across the surface of the part, pulling rapidly cooling filament out of the nozzle as it moves, leaving you with a blob. g. If it's after a G92 E0, it also causes the extruder to run forwards and actively extrudes a large pile of filament o...
by AlanKilian
Sat Feb 25, 2017 9:37 am
Forum: Troubleshooting
Topic: [Solved] G92 E0 causes a lot of extrusion.
Replies: 31
Views: 7968

Re: G92 E0 causes a lot of extrusion.

I'd like to go back to another discussion about G4 P0 and command queues. I will test this theory next week, but is Slic3r really generating incorrect G code by not adding a G4 P0 before every G92 E0? If a G1 followed by a G92 requires a G4 p0 in between them, the Slic3r is producing incorrect G cod...
by AlanKilian
Fri Feb 24, 2017 7:34 pm
Forum: Troubleshooting
Topic: [Solved] G92 E0 causes a lot of extrusion.
Replies: 31
Views: 7968

Re: G92 E0 causes a lot of extrusion.

Or just ignore all parameters on a G28 command if it's a delta configuration. I see no functional benefit to homing a single tower and it's begging for an eventual crash. I think you're confused a little. G28 doesn't home towers it homes axes. So just like G0 and G1 can move along the X axis (and n...

Go to advanced search