Firmware for Older 0.8.5 boards

User avatar
Lightpath
Printmaster!
Posts: 90
Joined: Fri Apr 11, 2014 5:09 am

Firmware for Older 0.8.5 boards

Postby Lightpath » Tue Mar 06, 2018 12:35 am

Hey all-

I have an older non-wifi Duet- 0.8.5. Does anyone know what the highest rev of firmware is that you can put on it? I can't seem to find a definitive answer, or perhaps I'm not 100% sure where to look.

I can get to 1.8.2 by installing 1.09 first, but after 1.8.2 it seems to lock up the board, so I have to start over. Likely I'm just missing a step, or doing it wrong, but since the older boards aren't the focus of a lot of the guides/tutorials I'm not sure if I even can go above 1.8.2.

Thanks-

Mark.

dc42
Printmaster!
Posts: 414
Joined: Mon Mar 07, 2016 10:17 am

Re: Firmware for Older 0.8.5 boards

Postby dc42 » Tue Mar 06, 2018 6:49 am

I presume you mean 1.18.2, not 1.8.2.

The latest version available is 1.21RC3.

I have two reports that using 1.20 or 1.21RC3, older Duets (0.6 and 0.8.5) may fail to start up if you have the IP address set to all zeros so that it uses DHCP and you have the Ethernet cable connected. Unfortunately I am unable to reproduce this. It's not impossible that this fault affects 1.18.2 as well, although nobody has reported it in that release.

A common reason for firmware upgrades failing is that you downloaded the HTML page describing the firmware binary instead of the firmware binary itself. Avoid this by downloading from the Release area at https://github.com/dc42/RepRapFirmware/releases.

Also bear in mind that you need to update DuetWebControl to a compatible version too. I recommend you rename your existing /www folder on the SD card to /www-109, create a new /www folder, and unzipping the new DuetWebCobntrol.zip into it.

HTH David

User avatar
Lightpath
Printmaster!
Posts: 90
Joined: Fri Apr 11, 2014 5:09 am

Re: Firmware for Older 0.8.5 boards

Postby Lightpath » Tue Mar 06, 2018 9:01 pm

Changed from dhcp to hard coded IP and my 1.18.2 installed board is now reachable!

Now to move on to try to install 1.21RC3. Can you go direct 1.18.2 to 1.21RC3 or do you need to go to 1.19 first?

Do you have a patreon where we can donate? Your work and support from the Duet is fabulous.

Mark.

User avatar
Lightpath
Printmaster!
Posts: 90
Joined: Fri Apr 11, 2014 5:09 am

Re: Firmware for Older 0.8.5 boards

Postby Lightpath » Tue Mar 06, 2018 9:17 pm

Damn, upgrading both firmware and web control to 1.21RC3 took minutes once I converted to hard coded IP. That might be a good thing to call out in the docs. :)

Thanks DC42!!!!


Return to “Duet”

Who is online

Users browsing this forum: No registered users and 1 guest