VIKI SD card reader with X3 Pro?

User avatar
mhackney
ULTIMATE 3D JEDDI
Posts: 5411
Joined: Mon Mar 26, 2012 4:15 pm
Location: MA, USA
Contact:

VIKI SD card reader with X3 Pro?

Postby mhackney » Sat Feb 14, 2015 9:16 am

I'm trying to set up my VIKI so I can use the microSD card reader. I have everything connected as per Panucatt's documentation but only, the Chip Select line (CS red on J3 on the VIKI (version 1) is shown going to 1 of 2 pins on the X3Pro that do not exist! Intact, the X3Pro drawings on their site also do not show this pin (#53). I am going to use one of the digital pins n EXP3

Sublime Layers - my blog on Musings and Experiments in 3D Printing Technology and Art

Start Here:
A Strategy for Successful (and Great) Prints

Strategies for Resolving Print Artifacts

The Eclectic Angler

User avatar
Nylocke
ULTIMATE 3D JEDDI
Posts: 1421
Joined: Sun Jun 23, 2013 1:43 pm
Location: Iowa

Re: VIKI SD card reader with X3 Pro?

Postby Nylocke » Sat Feb 14, 2015 11:04 am

It does exist. Currently there is a jumper on it, its for SD communication related stuff. Remove the jumper and connect it like shown in the first link. On the X3 Pro drawing its shown as a red octagon, right above J3 in that drawing.

User avatar
mhackney
ULTIMATE 3D JEDDI
Posts: 5411
Joined: Mon Mar 26, 2012 4:15 pm
Location: MA, USA
Contact:

Re: VIKI SD card reader with X3 Pro?

Postby mhackney » Sat Feb 14, 2015 11:48 am

Tyhe drawing on the X3 Pro page doesn't show this and here is a photo of my board - which does not have it:

FullSizeRender.jpg


Am I missing something? I tried using one of the open digital pins on EXP3 - pin 35 - and configured Repetier for that. Still no joy. The VIKI instructions also say to remove J12 from the back of the X3 Pro. I completely removed my card and scrutinized it with a magnifier and there is no J12 jumper or pads! You can actually see all of my hook ups in the photo above and except for the CS (red) wire, they match the VIKI setup page. I used pin 35 on EXP3 for CS.

My board looks like the drawing on the X3 Pro page: http://files.panucatt.com/datasheets/x3pro_wiring.pdf and not the drawing on the VIKI page that shows how to connect to the X3 Pro: http://files.panucatt.com/datasheets/vi ... iagram.pdf

Sublime Layers - my blog on Musings and Experiments in 3D Printing Technology and Art

Start Here:
A Strategy for Successful (and Great) Prints

Strategies for Resolving Print Artifacts

The Eclectic Angler

User avatar
Nylocke
ULTIMATE 3D JEDDI
Posts: 1421
Joined: Sun Jun 23, 2013 1:43 pm
Location: Iowa

Re: VIKI SD card reader with X3 Pro?

Postby Nylocke » Sat Feb 14, 2015 12:33 pm

Guessing yours is a V1.1 or something along those lines? Mines a V2, I have the jumper on the top of the board. You didn't see any bridged solder pads or anything underneath the board? Could you take a picture of the bottom?

If yours is older than the V1.1, it could be a possibility that your board may not be compatible with the SD card on the LCD. Mine actually broke when a wrench fell onto my Viki and hit the SD card. Probably some broken solder connection, but I've been using the built in reader since.

User avatar
mhackney
ULTIMATE 3D JEDDI
Posts: 5411
Joined: Mon Mar 26, 2012 4:15 pm
Location: MA, USA
Contact:

Re: VIKI SD card reader with X3 Pro?

Postby mhackney » Sat Feb 14, 2015 12:40 pm

Mine likely is a 1.1 or even 1.0 since it was one of the first batch. I do not have any sort of solder pad on the back side - I scrutinized it with a magnifier. I see how the X3 pad looks so had some idea what to look for. Nothing labeled J12 either. I've written to Roy to see if he can help. I took a photo of the backside while I had everything disassembled:

FullSizeRender.jpg

Sublime Layers - my blog on Musings and Experiments in 3D Printing Technology and Art

Start Here:
A Strategy for Successful (and Great) Prints

Strategies for Resolving Print Artifacts

The Eclectic Angler

User avatar
Nylocke
ULTIMATE 3D JEDDI
Posts: 1421
Joined: Sun Jun 23, 2013 1:43 pm
Location: Iowa

Re: VIKI SD card reader with X3 Pro?

Postby Nylocke » Sat Feb 14, 2015 12:44 pm

Probably a V1 if its from the first batch. May be too old to be compatible, at least in terms of that guide. Roy may have a workaround or an offer, considering when I got a faulty Viki they replaced both the Viki and the X3 for free.

User avatar
gsnover
Prints-a-lot
Posts: 28
Joined: Sat Mar 16, 2013 2:31 pm
Location: Bennington VT | Montreal, QC
Contact:

Re: VIKI SD card reader with X3 Pro?

Postby gsnover » Fri Jun 19, 2015 10:14 am

mHackney,

I have the same setup. X3 Pro v1.11 and Viki 1.0 LCD. Using the onboard SD card slot works fine, bu it is not accessible. Can not get the SD card to mount when plugged into the Viki. Did you find a solution?

using repetier v0.923
Rostock Max - Shakira "her hips don't lie"
Rambo 1.1 | Onyx | LCD | Marlin-for-Rostockmax-RamboLCD
KISSlicer


Return to “Azteeg X3 and X3 Pro”

Who is online

Users browsing this forum: No registered users and 1 guest