Octoprint disconnecting in consistently with certain prints

Talk about the web based OctoPrint controllers
shentheory
Printmaster!
Posts: 58
Joined: Wed Oct 22, 2014 11:54 am

Octoprint disconnecting in consistently with certain prints

Postby shentheory » Sun Feb 15, 2015 2:19 pm

I've got a Rostock Max V2, and i've had octoprint set up for a couple weeks now without issue.

Now suddenly, about every other model/gcode file, octoprint will disconnect and stop my print at the exact same place in the print, usually at the beginning, but always in the same place no matter how many times I restart the print. If I connect my Max to my computer and print the same Gcode through repeiter host, it prints fine. If I load up a different model/gcode file to octoprint, it will print it fine. Then after, I'll load a new gcode file, and it disconnects again. What could I try to go about troubleshooting this?

Much appreciated!!!

User avatar
bubbasnow
ULTIMATE 3D JEDDI
Posts: 1064
Joined: Fri Aug 02, 2013 4:24 pm
Location: Dayton, WA

Re: Octoprint disconnecting in consistently with certain pri

Postby bubbasnow » Sun Feb 15, 2015 3:01 pm

octoprint likes a very specific format of gcode, when you connect thru usb to your computer and print most interpreters account for capital letters and such but not octoprint (at least the old version i am using).

On octoprint what does the terminal window say when you experience the freeze?

User avatar
Jimustanguitar
ULTIMATE 3D JEDDI
Posts: 2628
Joined: Sun Mar 31, 2013 1:35 am
Location: Notre Dame area
Contact:

Re: Octoprint disconnecting in consistently with certain prints

Postby Jimustanguitar » Fri Jul 29, 2016 10:28 am

I'm playing with OctoPrint at work for the first time in over a year. I'm running the newest Jessie Lite version 0.13 I believe, and I'm seeing the same behavior. Print stops very shortly after starting the print, there are symbols in the terminal that look like black diamonds and odd fonts (i.e. not normal GCode), and the machine is locked until I give it a power cycle.



There are several settings in the Octo menus that note *Repetier next to them, as well as some options for how to handle errors, whether to cancel, disconnect, log them, etc.

Can anyone tell me what the correct settings are for the following fields?
Does anybody have a working Octo setup that they don't mind sharing? (is there a config or profile that's exportable?)

Image
Image
Image

User avatar
Jimustanguitar
ULTIMATE 3D JEDDI
Posts: 2628
Joined: Sun Mar 31, 2013 1:35 am
Location: Notre Dame area
Contact:

Re: Octoprint disconnecting in consistently with certain prints

Postby Jimustanguitar » Mon Aug 01, 2016 8:06 am

Is anybody successfully using OctoPrint right now?


Return to “OctoPrint”

Who is online

Users browsing this forum: No registered users and 1 guest