Dark camera

Talk about the web based OctoPrint controllers
int2str
Printmaster!
Posts: 196
Joined: Tue Nov 19, 2013 8:38 pm

Dark camera

Postby int2str » Thu Jan 23, 2014 5:31 pm

Running OctoPrint on OctoPi using the Raspberry Pi Camera.

The web cam image is way too dark. As in, black screen unless I shine a flashlight directly at the lens, resulting in a bright spot.
Does anybody know a way I can crank the brightness/ISO sensitivity?

Thx

User avatar
bubbasnow
ULTIMATE 3D JEDDI
Posts: 1064
Joined: Fri Aug 02, 2013 4:24 pm
Location: Dayton, WA

Re: Dark camera

Postby bubbasnow » Fri Jan 24, 2014 5:39 pm

I would try another webcam and see if it works better?

if not you can hook the PI up to a monitor and run raspian GUI mode and run the app to see if there are any settings you can adjust.

I am using a logitech camera on the 2014-01-07 weezy octo pi and i can see everything ok.

User avatar
daftscience
Printmaster!
Posts: 205
Joined: Sun Jan 13, 2013 12:37 pm

Re: Dark camera

Postby daftscience » Sun Jan 26, 2014 1:49 am

If you're using mjpg-streamer then point your browser to that port (http://ip:8080) and click on the control link. From there you should be able to adjust the camera settings.


http://ip:8080

User avatar
foosel
Noob
Posts: 4
Joined: Fri Mar 08, 2013 8:56 am
Location: Obertshausen, Germany
Contact:

Re: Dark camera

Postby foosel » Sun Jan 26, 2014 6:26 am

While I've not yet figured out what's causing this (since my own RaspiCam I use for testing works perfectly fine with the current default settings in OctoPrint), some people have reported better results with changing the exposure or image mode options of their cam.

OctoPi allows to do this via the file /boot/octopi.txt which can also be directly accessed as octopi.txt when you just put the SD card into a card reader and take a look at it in your Windows or (AFAIK) Mac explorer thingy. RaspiCam settings can be configured via the config switch camera_raspi_options:

Code: Select all

### additional options to supply to MJPG Streamer for the RasPi Cam
#
# See https://github.com/foosel/OctoPrint/wiki/MJPG-Streamer-configuration
# for available options
#
# Defaults to 10fps
#
#camera_raspi_options="-fps 10"


Remove the leading # and then add options as needed. People reported success by settings the cam into night exposure mode, so try changing the above to this:

Code: Select all

### additional options to supply to MJPG Streamer for the RasPi Cam
#
# See https://github.com/foosel/OctoPrint/wiki/MJPG-Streamer-configuration
# for available options
#
# Defaults to 10fps
#
camera_raspi_options="-fps 10 -ex night"


Save, reboot, keep fingers crossed ;)

int2str
Printmaster!
Posts: 196
Joined: Tue Nov 19, 2013 8:38 pm

Re: Dark camera

Postby int2str » Sun Jan 26, 2014 5:04 pm

Sweet, working now, thanks!


Return to “OctoPrint”

Who is online

Users browsing this forum: No registered users and 1 guest