X-Y shift during printing

A pre-assembled Delta Printer that can print a 6" cube 8" tall!
sbarner
Plasticator
Posts: 6
Joined: Mon May 19, 2014 9:26 am

X-Y shift during printing

Postby sbarner » Wed Dec 30, 2015 1:22 pm

Actually, we're having a number of issues, and since they may be related, I'll try to describe them all. First, the extruder seems to shift part way through most prints. Sometimes this happens after the first couple layers, and sometimes part way through. On at least one print, there were two cases where there appears to be two slight shifts on one side of the model, but they do not appear on the other side! This can be seen in the photos of the model that is the word "CONFIDENT" (a project for some elementary school students). Some of the other photos show similar issues with other prints. This has happened a lot over the past 20 prints or so.
P1000588.jpg
P1000587.jpg

P1000572.jpg
P1000576.jpg


The second problem can be seen in the photo of the bottom of the print of the word "BEAUTIFUL." We get this a lot and have for quite some time now. There does not seem to be good bonding between rows of filament laid down on the first layer. This is exacerbated when on the inside of a large-radius curve. It seems as if the outside shell is shrinking before the next strand has a chance to bond with it, leaving a gap. There are often gaps in the filament on the first layer and these then are repeated in subsequent layers.
P1000589.jpg


There seems to be an inordinate amount of excess filament strands, at least compared to other 3D printers I have used. This seems to have gotten a lot worse over the past few months.

There are two photos of a failed print, with one taken from the side with which I have attempted to show how the print both shifted and started printing with the Z axis at a slight angle, resulting in a wedge-shaped print.
P1000592.jpg
P1000595.jpg


The photo of the objects on the printer bed is intended to show the extra shells that we are getting, often on the first layer, but sometimes continuing up quite a ways, like some type of cancerous growth or birth defect in a human.
P1000570.jpg


We had been having problems with the pins that connect the support arms to the extruder walking out of the universals, but this did not happen during any of these prints. I have adjusted the Z-axis and leveled the bed as best I can, to the point where on part of the bed at least, the extruder is so close that the filament doesn't come out on the first layer. It is very difficult to get the first layer completely flat with this printer. I have noticed that sometimes it seems that the filament stops feeding, part way through a print. I have tried adjusting the belts on the towers, and making sure that nothing has come loose. Quite frankly, I am skeptical of the very design of this printer, as there doesn't seem to be enough precision designed into its components to support a scheme that requires such accuracy as is required when tiny changes are amplified in the position of the extruder. This, however, does not explain the big shifts that are ruining many of our prints.

I've used enough 3D printers to have quite low expectations for these entry-level extrusion machines, but our success rate on this machine has gone from mediocre to abysmal.

Stephen Barner
South Burlington High School, Vermont

User avatar
Xenocrates
ULTIMATE 3D JEDDI
Posts: 1543
Joined: Wed Sep 23, 2015 2:55 pm

Re: X-Y shift during printing

Postby Xenocrates » Wed Dec 30, 2015 2:15 pm

Tell me, are those U-joints metal? Have they been lubricated at all? That the pins are walking out of them indicates that there is a mechanical fault with that section of the assembly. Tighten the retaining screw (I assume it is similar to a Rostock in that it has retaining screws that clamp the pins in place on both the effector and the carriage (Although I haven't had U-joints on mine for a bit, so the memory is not as clear as it could be)

As far as the extra shells, do they occur on other printers when using the same model and slicing settings? (I presume that as you mentioned that you had experience with Cartesian machines, that there are some available. if not, feel free to PM me both the STL and the G code used to actually print)

Has the calibration of the unit, such as the Horizontal radius and endstop offsets been adjusted since the printer was delivered? If so, do you recall when this was last done? A problem, unfortunate as it is, is that Delta machines, due to the more complex geometery, need more initial calibration and ongoing calibration if there are environmental swings. As you've indicated you're in a school, I'm fairly certain you get environmental swings (being near a window is enough, over time)

Have you checked the carriage adjustment and their eccentric cams? (I presume this machine predates the IM carriages, as there was a brief window where IM carriages were shipped with U-joints)

I suspect that the filament feed issue is a combination of factors. A hot extruder motor, which can be fixed by lowering the current in the firmware, a clogged hobbed gear, which can be cleared with a brass brush, and a filament temperature that is slightly low.

Layer shifting may be caused by the hotend catching on previous traces when moving, which can be helped by activating Z lift (Or Z hop depending on the slicer package), lowering speed slightly, or increasing temperature. It can also be a belt or cheapskate issue, or the driver overheating. Make sure the Rambo fan is working and that there is some airflow.

By the bed being unlevel, is there a distinct slope, or is it a sort of ringed issue? If the former, then shimming the bed with aluminum foil will help. If the latter, then the horizontal radius is out of whack, and needs adjustment.

I hope you can get a number of these issues resolved. If not, let us know what persists, if any new problems come up, and and if anything gets worse or better after a bit of fiddling. We're here most of the time to help. If you're really stumped, Geneb or the folks who actually work for SeemeCNC like JJ can help with the heavy wizardy. Don't be afraid to ask them. Or the rest of us.

Happy new year to you, and your students.
Machines:
Rostock Max V2, Duet .8.5, PT100 enabled E3D V6 and volcano, Raymond style enclosure
Automation Technology 60W laser cutter/engraver
1m X-carve router

Sic Transit Gloria Mundi
01-10011-11111100001


Return to “ORION”

Who is online

Users browsing this forum: No registered users and 3 guests