Random layer fan startup

Talk about the Repetier Host software here (http://repetier.com)
Post Reply
esbowman
Printmaster!
Posts: 64
Joined: Fri Apr 18, 2014 11:25 pm

Random layer fan startup

Post by esbowman » Fri May 02, 2014 9:27 pm

Using Repetier Host Mac V.56

So i've noticed on the last couple of prints, that my PLA layer fan will randomly start spinning. In Repetier I can see the fan speed slider bounce around while it's doing that. I have to click on the Fan On/OFF button to make it stop.

Can bad G-code cause the fan to start? If not, could it be that it's getting some weird interference which makes it start? I've looked to see if anything is shorting out and I can't see anything obvious. I spliced, soldered, and even put shrink wrap over the red and black wires individually to eliminate any possible shorting. Can this be a bug in Repetier perhaps?

Polygonhell
ULTIMATE 3D JEDDI
Posts: 2430
Joined: Mon Mar 26, 2012 1:44 pm
Location: Redmond WA

Re: Random layer fan startup

Post by Polygonhell » Fri May 02, 2014 9:33 pm

If you see the slider bouncing around in the host software the most likely thing is bad GCode.

esbowman
Printmaster!
Posts: 64
Joined: Fri Apr 18, 2014 11:25 pm

Re: Random layer fan startup

Post by esbowman » Fri May 02, 2014 10:09 pm

Good to know it's likely not a hardware issue.

So if it is a GCode issue, how would I go about disabling that fan altogether when I'm printing in ABS? What command would I be looking for in the GCode? BTW, I used the latest stable release of Slic3r to generate the code. Thanks!

Polygonhell
ULTIMATE 3D JEDDI
Posts: 2430
Joined: Mon Mar 26, 2012 1:44 pm
Location: Redmond WA

Re: Random layer fan startup

Post by Polygonhell » Fri May 02, 2014 10:37 pm

I think M106 is the fan control GCode.
You might want to check your settings in the cooling tab in slicer, I don't use it, so I can't get more specific.

Post Reply

Return to “Repetier Host”