Rambo eeprom timout

The RAMBo board is finally here, and here's a place to talk about it!
razzle
Plasticator
Posts: 15
Joined: Mon Jan 30, 2017 6:01 pm

Rambo eeprom timout

Postby razzle » Wed Feb 01, 2017 6:44 pm

Hi everyone.

Having some issues with the rambo in my new V3 build.
I have submitted a support ticket with Seemecnc and am currently going through all the troubleshooting with them.
Just thought id also post it here to see if the collective knowledge could help the process along a bit.
Problem is that I get a timeout error just trying to run the eeprom clear sketch. on the rambo.

Now this is not my first rodeo but it is my first rambo. :lol:

I have been through the list here with no change...
https://seemecnc.zendesk.com/hc/en-us/a ... eout-Error

Confused to say the least as I have never had any issues with Ramps 1.4 or MKS 1.4 boards before.

Any and all help appreciated.

Dale
Current printers
Rostock Max V3 (built but not printing yet)
3 x Flashforge Creator Pros 2016
3 x Prusa i3 mk2
Flashforge finder
Wombot Modus
Cocoon Create (Wanhao i3)

Eric
Printmaster!
Posts: 726
Joined: Sat Aug 18, 2012 4:09 am
Location: Chula Vista, CA

Re: Rambo eeprom timout

Postby Eric » Wed Feb 01, 2017 7:37 pm

I'm assuming this is a communications issue, and has nothing to do with the actual eeprom on the processor.

You get the same result with any sketch, right? The blink example, for instance?

razzle
Plasticator
Posts: 15
Joined: Mon Jan 30, 2017 6:01 pm

Re: Rambo eeprom timout

Postby razzle » Wed Feb 01, 2017 10:36 pm

Hi Eric,

Thanks for your input.
You are correct, I get it with any sketch.
I have not tried the blink sketch specifically on this board.

On the topic of blinking though.
The status LED flashes flatout all the time regardless of what is going on.
which is odd behaviour at best.
Even just after I turn the printer on, the power light turns on then the activity/status light just starts blinking.
I let it sit for 10 mins and it just kept going.
Plug the USB into my PC and it still does it, no matter what is going on.

Only thing that stops it blinking is the reset button, and that's only for a second.
Current printers
Rostock Max V3 (built but not printing yet)
3 x Flashforge Creator Pros 2016
3 x Prusa i3 mk2
Flashforge finder
Wombot Modus
Cocoon Create (Wanhao i3)

razzle
Plasticator
Posts: 15
Joined: Mon Jan 30, 2017 6:01 pm

Re: Rambo eeprom timout

Postby razzle » Wed Feb 01, 2017 10:38 pm

Just to add.

I have tried with 2 different PC's with the exact same results..
Current printers
Rostock Max V3 (built but not printing yet)
3 x Flashforge Creator Pros 2016
3 x Prusa i3 mk2
Flashforge finder
Wombot Modus
Cocoon Create (Wanhao i3)

Dale Eason
Printmaster!
Posts: 191
Joined: Fri Mar 06, 2015 8:56 pm

Re: Rambo eeprom timout

Postby Dale Eason » Wed Feb 01, 2017 11:10 pm

It does sound to me like you are having trouble just getting your PC to talk to the board.

Other processors similar to the Arduino on the rambo board that I have played with come with the blink program already installed and so when you first power them up that is what they do. They blink an led on the board. It has been too long ago for me to remember if that is what the rambo does when you first turn it on. But it could be. If that is so then you are just having trouble getting your PC to talk to it. That could be you are using the wrong Com port or a settings issue with the Arduino IDE that you need to use to download the program.



Dale Eason

razzle
Plasticator
Posts: 15
Joined: Mon Jan 30, 2017 6:01 pm

Re: Rambo eeprom timout

Postby razzle » Wed Feb 01, 2017 11:21 pm

Yeah it does seem like a communication issue but I can confirm that I am on the correct port, COM3 in my case.
I have tried both though, COM 1 & 3 with no change.
Correct board selected with the correct processor and COM.
I have opened up device manage and can see the COM 3 port change when it detects the rambo.
All very frustrating....
Current printers
Rostock Max V3 (built but not printing yet)
3 x Flashforge Creator Pros 2016
3 x Prusa i3 mk2
Flashforge finder
Wombot Modus
Cocoon Create (Wanhao i3)

razzle
Plasticator
Posts: 15
Joined: Mon Jan 30, 2017 6:01 pm

Re: Rambo eeprom timout

Postby razzle » Fri Feb 03, 2017 6:46 am

Hi again.

Just an update.
i managed to get the eeprom clear sketch to work this evening!
what i ended up doing was holding in the reset button on the rambo, then turning the printer on whilst still holding it in.
i had the sketch ready to go before all this.
I then released the reset button and clicked upload about half a second later.... success!
It completed the upload with no problem.
Current printers
Rostock Max V3 (built but not printing yet)
3 x Flashforge Creator Pros 2016
3 x Prusa i3 mk2
Flashforge finder
Wombot Modus
Cocoon Create (Wanhao i3)


Return to “RAMBo”

Who is online

Users browsing this forum: No registered users and 1 guest