Page 1 of 1

V3 Layer Shift Mystery

Posted: Thu Feb 08, 2018 2:37 pm
by stonehenge360
Hi Guys,

I currently have 5 V3's in operation. I have been upgrading them to the Duet Wifi controller, and currently have 3 running Duet and 2 running rambo.

I am having a problem with layer shift on one of the machines converted to the Duet. I am printing the same files on all printers with the same filament and settings, and the problem is isolated to the single printer.

- The problem only occurs when the print is spread out over a large portion of the bed, almost from edge to edge. If I print one or two smaller prints, there is no layer shift at all.
- The issue is not related to the prints being centered either. I can print a single print anywhere on the bed, even at the very edge, and it will be fine, but then if I fill the bed with prints, the layer shift comes back. Look at the photo of the two pieces that were printed together. You can see that the layer shifts stopped once the printer was done with the short piece and was only printing the taller piece.
- The layer shift appears to be periodic in nature, not random.

Things I Have Tried:
- Replaced all three stepper motors thinking the bearings were going bad in one of them
- Replaced all three belts thinking the teeth were skipping periodically
- Tightened the grub screws in all three pulleys
- Replaced the entire HE280 hotend
- Checked for overheating of the motors and driver chips, all can be touched without burning yourself
- Checked my acceleration and jerk settings compared to the old rambo setup. The rambo was actually more aggressive.
- Replaced the power supply, heated bed, and glass surface.
- Again, I have two other V3's with Duets that I have built, and they do not have the problem

If it matters, I am running S3D. I have yet to upgrade the HE280 to work with Duet calibration, so I am doing it manually which is slow but it works. I am printing PETG at 275F with 60F bed.

As you can see, I have ruled out the motors, belts, controller, print file, hotend, wiring, , bed, accel, and jerk settings.

If anyone has any ideas please let me know, I feel like I have been looking at this problem for too long and I can't see the answer that is right in front of me. :shock:

Re: V3 Layer Shift Mystery

Posted: Fri Feb 09, 2018 7:56 am
by geneb
Have you tried bumping up the current to the steppers?

g.

Re: V3 Layer Shift Mystery

Posted: Fri Feb 09, 2018 9:07 am
by stonehenge360
geneb wrote:Have you tried bumping up the current to the steppers?

g.


I have not. I'm not positive what they are set to right now (I will check when I get home tonight), I used the settings posted on the tutorial on sublime layers.

Do you have a recommendation for what the current should be set to?

Thanks,

Re: V3 Layer Shift Mystery

Posted: Fri Feb 09, 2018 2:31 pm
by geneb
Try 1200 and see how it goes.

Also make sure the power supply is putting out at least 12v while the bed and hot end are heating up.

g.

Re: V3 Layer Shift Mystery

Posted: Sun Feb 11, 2018 12:37 pm
by stonehenge360
The motors were set to 1000 mA current. I upped them to 1200 with no change in the layer shift.

I am still getting perfect prints if the total size of the prints is maybe half of the bed, but if it is spread out further than that, the layer shifting is very apparent.

My voltage is 11.9-12.2 according to the duet web interface.

I think I am going to try dropping a spare duet into the printer to see if it helps.

Re: V3 Layer Shift Mystery

Posted: Sun Feb 11, 2018 2:54 pm
by dc42
After a layer shift has occurred, run M122 and check whether any under-voltage events have been recorded.

Re: V3 Layer Shift Mystery

Posted: Mon Feb 12, 2018 6:27 pm
by stonehenge360
Doesn't look like it had any under-voltage events.


Used output buffers: 3 of 32 (10 max)
=== Platform ===
RepRapFirmware for Duet WiFi version 1.19 running on Duet WiFi 1.0
Board ID: 08DGM-95BNL-MGPSN-6JKDJ-3S46K-1LWVW
Static ram used: 21176
Dynamic ram used: 96136
Recycled dynamic ram: 1472
Stack ram used: 1304 current, 9224 maximum
Never used ram: 3064
Last reset 21:01:13 ago, cause: software
Last software reset reason: User, spinning module GCodes, available RAM 3224 bytes (slot 1)
Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
Error status: 0
Free file entries: 10
SD card 0 detected, interface speed: 20.0MBytes/sec
SD card longest block write time: 375.6ms
MCU temperature: min 36.6, current 37.3, max 43.1
Supply voltage: min 11.6, current 12.3, max 12.4, under voltage events: 0, over voltage events: 0
Driver 0: stalled standstill
Driver 1: stalled standstill
Driver 2: stalled standstill
Driver 3: stalled standstill
Driver 4: standstill
Date/time: 2018-02-12 18:26:08
Slowest main loop (seconds): 0.378906; fastest: 0.000000
=== Move ===
MaxReps: 5, StepErrors: 0, FreeDm: 240, MinFreeDm 120, MaxWait: 4278541ms, Underruns: 0, 0
Scheduled moves: 188871, completed moves: 188871
Bed compensation in use: none
Bed probe heights: 0.000 0.000 0.000 0.000 0.000

Re: V3 Layer Shift Mystery

Posted: Wed Feb 28, 2018 10:21 am
by stonehenge360
Just to close this out if someone else is having a similar issue, I discovered that the wheels inside the cheapskates were wobbling, causing all three carriages to shift, and the hot end to twist. I replaced the wheels and the problem went away completely.

Re: V3 Layer Shift Mystery

Posted: Wed Feb 28, 2018 12:34 pm
by dc42
Thanks for letting us know.