FSR Calibration with the Duet Wifi

Having a problem? Post it here and someone will be along shortly to help
Post Reply
wdmarine
Prints-a-lot
Posts: 24
Joined: Sun May 07, 2017 2:08 pm

FSR Calibration with the Duet Wifi

Post by wdmarine » Sun Jun 04, 2017 2:13 am

I have a Rostock Max v3 with FSR probing, the Trick Laser FSR plate, and the Duet Wifi board.

I am trying to do a large (230 mm widest) print and am consistently having the first layer around the perimeter not adhere at all. Small prints (~ 50 mm widest) adhere perfectly. The bed is the stock glass on Trick Laser's heat spreader, held down at three points. The only thing on the glass is hair spray (PEI coming soon). It is clear to me that the issue is the Z height is too high.

I am running the Duet's 13 point configuration and getting the same Z height every time. What is confusing me is I am going into the config-override.g file and increasing the Z height, restarting the Duet, and it doesn't seem to do a thing. The Z height is still too high and so there is no adhesion. Perhaps I am missing something about how this works.

Also, does Duet's 13 point 6 factor calibration set the delta radius or do I have to?

I appreciate any help.

Update: I just checked the height of the nozzle above the bed at Z0 and it is about 3 mm too high. This is after doing Duet's calibration.Checked the bed and it is flat.

gchristopher
Printmaster!
Posts: 174
Joined: Mon Dec 08, 2014 2:09 am

Re: FSR Calibration with the Duet Wifi

Post by gchristopher » Sun Jun 04, 2017 2:51 am

I'm just starting with the duet, and have never used override.g

Have you tried changing the values for the G31 to adjust the assumed probe distance from the bed? I guess it'd need to be Z0 for FSRs?

G31 X0 Y0 Z1.20 P500 ; Set the zprobe height and threshold (put your own values here)

wdmarine
Prints-a-lot
Posts: 24
Joined: Sun May 07, 2017 2:08 pm

Re: FSR Calibration with the Duet Wifi

Post by wdmarine » Sun Jun 04, 2017 3:01 am

Thank you for the quick reply!

It turned out to be user error. Earlier today I changed the 13 probing points in the bed.g file to rotate them 45 degrees. I used a spreadsheet to do this and in constructing the G30 codes I made all the P parameters have a value of 0 (zero) and I left off the S6 parameter on the last G30 command. So, the Duet was doing just what I asked it to - go through the motions of calibrating, but don't actually do it! This explains why even if I tilted the bed up a small bit, calibrating wasn't changing the M665 values.

Post Reply

Return to “Troubleshooting”