Page 1 of 1

LCD Smart Controller not working with RAMPS :'(

Posted: Mon Mar 20, 2017 9:24 pm
by Axlspinedoc
I have been building my very own 3D printer since last year and I'm on the last phase of construction: The Firmware Installation.
I Installed Repetier v092 with the use of their Web App ( to configure the whole thing.
I became very familiar with the construction of Rostock printers, so I wanted my printer to be somewhat alike in the software aspect. I bought a RepRap Discount Smart LCD Controller, just like the one that comes with the Rostock.

The problem is: The LCD isn't working. The printer boots-up and the screen comes on, but I see strange symbols and numbers. I enabled sound effects in the configuration to identify if the screen was recieving input. The printer does recognize the pot and even the Stop button on board. The LCD was tested outside the printer and with the 12V Supply and alone with the USB 5V supply. In either case the behavior was the same.

I checked both ribbon cables. I flipped them, changed them, but there's only one way in which the screen sort of works. When both Exp1 and Exp2 are connected in their respective slots and with the key orientation, the LCD comes on and responds to inputs, but it is illegible because of the symbols and stuff.

I have already tried making the adjustments in the configuration.h file myself while downloading the Master Firmware from Repetier, but still no changes. I included the u8glib library in the configuration.h file and in the libraries of arduino. I tried Arduino versions 1.0.6 and 1.6.13 to upload the code but still I get the same result.

I include a photo of the RAMPS and the LCD with its Ribbon Cables. It would be greatly appreciated if someone helps me getting my baby to work.

PS: The one who gets the solution will get the right to name my printer